Applies to

StifleR 2.x

Symptoms

This will usually only be seen in a lab/testing scenario where the machines are “cleaned” manually or by script between installations. Some customers may be using such scripts in a production environment.

After the StifleR server and/or clients have been cleaned and reinstalled you may notice that the client count has increased for no apparent reason. Upon digging a little deeper a search in the dashboard for a client will show two entries (one with ?) and in WMI there will be client entries with duplicate names but different GUIDs.

Cause

The StifleR Server databases are stored in the

%ProgramData%\2Pint Software\StifleR\Server\DataBases

folder.

This folder and contents are preserved during an uninstall or upgrade.

Client information is stored in the Registry on the client which needs to be preserved in order to keep track through reinstallations.

There is a script that was distributed StifleR_Client_Installer.ps1 to assist with v1.9 client upgrades and installations. This script uninstalled the existing client and then cleaned up, amongst other things, the Stifle Registry keys. The effect of this is that when the new client installation starts it will register with the StifleR Server under the same machine name but a new GUID. This results in a duplicate entry.

Solution

Depends on the scenario.

For fresh testing iterations ensure that the Registry on the clients are deleted and the ProgramData folder is deleted on the Server.

For Client re-installations make sure that the registry is left intact.

For Server re-installations make sure that at least the DataBases folder is deleted.

If this has affected your production environment then some scripting jiggery-pokery can be used to clean out duplicate entries. Drop us a line should this be the case and the 2Pint feel good squad will rush to assist.