Applies to
iPXE Server 2.7
Symptoms
The first initial boot can timeout and go into “Contacting Server” retry mode
Cause
Since the PowerShell script generates the BCD files on the fly, unless already created the first initial boot can timeout and go into retry mode as the creation of the BCD file takes too long. This is typically the case when not using the HTTP server and having the iPXE Boot Loaders enabled.
Depending on how many image BCD files are being returned it can take a retry or two before the machine is prompted with a menu or booting to an image. The second attempt will not go into retry as the BCD files will be reused. Since starting and stopping the service causes the temporary files to be cleaned out this is likely to happened in labs where starts and stops of the service is common.
Solution
Enable the HTTP service in the configuration file.