Applies to
StifleR Server

Symptoms
When installing onto a server that has had v1.7 previously installed, the installer fails with a message advising:

There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.

Cause
In this instance the error was caused by a failure by the 1.7 uninstall to clean out WMI.

Solution
Use wbemtest to delete the root\stifler class of “Connections”

Or

Adapt the following PowerShell snippet to check for an delete the entire namespace before installation:

 

if (get-wmiobject -namespace root -class __NAMESPACE -filter "name='StifleR'")

{

gwmi -Namespace root -class __Namespace -Filter "name = 'StifleR'" | rwmi

}